Announcement

Collapse
No announcement yet.

A WinXP problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • A WinXP problem

    Hi there;

    I have the following problem concerning winXP:

    It seems that whenever I start a program(--> game ) in XP that has been designed for a OS lower then Win98 the program just starts and then freezes the first screen. This is true for all DOS applications but also other older games e.g. Birth of the Federation, but I can run Jagged Alliance2, Counterstrike etc.
    There are no changes in the problem if I change compatibilty options.
    Interesting to note is that programs executed via dosbox don't have this problem but unfortunately dosbox can't provide the power for any of my games except "Red Storm Rising".

    So, if anybody knows a good hint how to fix this or has any suggestions an answer would be nice.

    thanks;
    clark

    O yeah by the way, the system is an AthlonXP 1800+ with a GForce 4 5200FX, 256MB RAM and onboard sound.
    "A platoon of Chinese tanks viciously attacked a Soviet harvester,
    which was peacefully working a field near the Soviet-Chinese border.
    The harvester returned fire and upon destroying the enemy
    returned to its home base."

  • #2
    Since I don't own any of those games, I can't be too much help. Of the old games I own, TOAW II and Jane's USAF are the only two that gave me trouble. A general solution that is regularly proposed is dual-booting. It's not the easiest thing in the world, and I haven't tried it, but this appears to be the best solution for those games no longer supported by it's development company.

    http://www.microsoft.com/windowsxp/p.../multiboot.asp
    "As soon as men decide that all means are permitted to fight an evil, then their good becomes indistinguishable from the evil that they set out to destroy."-Christopher Dawson - The Judgement of Nations, 1942

    Comment


    • #3
      Have you tried the following?
      Right click on the icon and select Properties and then the Compatibility tab, and then select Run in Campatibilty Mode - Win95.

      Comment


      • #4
        Originally posted by Prester John
        Have you tried the following?
        Right click on the icon and select Properties and then the Compatibility tab, and then select Run in Campatibilty Mode - Win95.
        Thx, but read my post again Prester!!!
        "A platoon of Chinese tanks viciously attacked a Soviet harvester,
        which was peacefully working a field near the Soviet-Chinese border.
        The harvester returned fire and upon destroying the enemy
        returned to its home base."

        Comment


        • #5
          Originally posted by mr_clark
          Thx, but read my post again Prester!!!
          As long as you have tried the manual settings and not just the Compatability Wizard.

          The manual method also allows you to try different display settings.

          This may also be an excuse to update drivers and see if any improved backward compatibility has been added.

          Comment


          • #6
            I had some similar problems and was not able to solve them. I guess that the problem is related to NT technology which seems to be used in XP. The best way to solve seems to be having two Operating Systems in your computer.
            Cual lidian bien, sobre dorado arzón
            Mio Cid Ruy Diaz, el buen lidiador;
            Minaya Alvar Fáñez, que en Zorita mandó;
            Martín Antolínez, el burgalés de pro...!

            Comment


            • #7
              O.K. so the current situation is that thanks to Delta's and Minaya's suggestions I will get a new harddrive and install my old Win98 aditionally to XP.


              Looking forward for other replies,
              clark
              "A platoon of Chinese tanks viciously attacked a Soviet harvester,
              which was peacefully working a field near the Soviet-Chinese border.
              The harvester returned fire and upon destroying the enemy
              returned to its home base."

              Comment


              • #8
                A likely suspect for your problem is the sound. Most DOS games require a DOS sound driver. XP doesn't emulate DOS sound drivers.

                A way to test if this is the case is to see if your DOS game has a means to disable the sound (ie. select no sound in the configuration). Disable the sound and then try the game. If the game loads normally, bingo - you found the culprit. Fixing it is matter of setting up a DOS based sound driver which works for your sound card.

                I know the above is a likely suspect because I've had DOS game lock up on me on several occasions. And in every occasion for me, the DOS sound was the culprit.

                Comment


                • #9
                  My guess would be graphic card problems. Try to set your color depth to 16 or 256 bit, not true color. And try to reduce the screen resolution to 640x480. This helped with a couple of dos and win 95 games quite. Still some games won´t run for sure, as silent hunter II or panzer general. They crash every time, the game treis to play some videos. So, I´m quite sure, this is some kind of graphic card driver problem as well.
                  Maj. Reismann: "Kill every officer in sight!"
                  soldier: "Ours or theirs?"

                  Comment


                  • #10
                    Originally posted by Black Moria
                    A likely suspect for your problem is the sound. Most DOS games require a DOS sound driver. XP doesn't emulate DOS sound drivers.

                    A way to test if this is the case is to see if your DOS game has a means to disable the sound (ie. select no sound in the configuration). Disable the sound and then try the game. If the game loads normally, bingo - you found the culprit. Fixing it is matter of setting up a DOS based sound driver which works for your sound card.

                    I know the above is a likely suspect because I've had DOS game lock up on me on several occasions. And in every occasion for me, the DOS sound was the culprit.
                    Tried this already but didn't work out.

                    Also tried some emulators for same effect.


                    @hydrou

                    'k, guess I try it with preresetting the graphics mode.
                    "A platoon of Chinese tanks viciously attacked a Soviet harvester,
                    which was peacefully working a field near the Soviet-Chinese border.
                    The harvester returned fire and upon destroying the enemy
                    returned to its home base."

                    Comment


                    • #11
                      Well, all the hints didn't really work so I just bought a new HDD today and formated a FAT partition for win98.
                      Hope the stuff will work out in the end...

                      nevertheless thanks for your assistance,
                      clark
                      "A platoon of Chinese tanks viciously attacked a Soviet harvester,
                      which was peacefully working a field near the Soviet-Chinese border.
                      The harvester returned fire and upon destroying the enemy
                      returned to its home base."

                      Comment

                      Latest Topics

                      Collapse

                      Working...
                      X